WIZnet Developer Forum

WizFi630S: Ethernet/LAN to Wi-Fi bridge/gateway

Dear,

We would like to evaluate WizFi630S module as a (Ethernet) cable replacement.

So we have ‘Network Device’ that is currently connected by LAN/Ethernet cable to network switch. We would like to replace the cable by a wireless connection. From the manual it is not clear to me if this is possible? Can someone confirm this is possible?

Please refer to the picture below for the required setup.

The network does not use DHCP. All devices have static IP.
The WizFi630S modules are clients to the access point and shall not have IP address themselves. They should act as a pass through for the Ethernet network traffic of the ‘Network Devices’.

Thanks in advance and best regards!

3sLLorez

Hi

I tested the function that you wanted. and I found out how to set the module to run that function.

I set up the module and did ping test.

  1. ping test from a laptop to network device.
  2. ping test from network device to laptop
  3. ping test from network device to google

and the result of above tests worked well.

It is a bad news that the WizFi630S has a IP address(192.168.1.100). because WizFi630S have to connect to AP using Client Mode.
but you don’t have to worry about the IP of Client mode.

Above connection I tested allow Network Device to have two subnet.
However, the Network device can use the subnet of the AP instead of WizFi630S’s subnet.

please refer to the image and description in the following link.
https://oldwiki.archive.openwrt.org/doc/recipes/relayclient

Hi Daniel

Could you share your settings for this. I’ve yet been successful at reproducing your results. I’m aware that I might have to change SSID’s and such.

BR
Tommy

OK, Tommy

this is setting parameters that I tested.

first of all, you should install ‘relayd’ package into the module.

$ opkg update
$ opkg install relayd
$ /etc/init.d/relayd enable
  1. /etc/config/network
  • add configuration
config interface 'repeater_bridge'
        option proto 'relay'   
        option network 'lan wwan'
  • change ip address of lan interface to different subnet.
    below subnet of this configuration is ‘192.168.2.1’. but your network device should have a IP of AP’s subnet like ‘192.168.1.2’
config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.2.1'   <<< here
        option ifname 'eth0.1'
  1. /etc/config/wireless
  • enable wifi station interface and set information about AP
config wifi-iface 'sta'
        option device 'radio0'
        option mode 'sta'
        option ifname 'apcli0'
        option encryption 'psk2'
        option ssid 'MySSID'      <<< here
        option key 'MyPassword'      <<< here
        option network 'wwan'
        option disabled '0'     <<< here
  1. /etc/config/firewall
  • accept forwarding packet of lan interface.
config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'  <<< here
        option network 'lan repeater_bridge wwan'   <<< here
  1. /etc/config/dhcp
  • disable(ignore) dhcp server function of lan interface
config dhcp 'lan'
        option interface 'lan'
        option dhcpv6 'server'
        option ra 'server'
        option ignore '1'         <<< here
        option ra_management '1'
  1. save configuration
$ uci commit
$ reboot

Thanks Daniel

In the user manual you have a mode described as AP Client Mode[Multi Bridge Mode]. This mode was used in old wizfi630 cards to give exactly the relayd functionality. Togheter with a second card in AP mode one would have a “transparent” non-NAT/WAN network across LAN and WiFi.

Shouldn’t this AP Client Mode[Multi Bridge Mode] be supported without installing relayd?

/Tommy

Hi Tommy

The WizFi630, old one, was built with custom Firmware from us.
however the WizFi630S, new one, is based on OpenWrt embedded linux. because of extensibility and reliability.

I think there are many way to set up.
and one of the ways is using relayd.

I searched about that on online.
may be you can configure a WizFi630S as a bridge mode without relayd.
https://openwrt.org/docs/guide-user/network/wifi/bridgedap

192.168.1.1 is a local IP address that is used to access the admin panel. 192.168.l.l is set by routers and modem company as the default gateway to access the Admin Panel of the router from where you can change default settings of your router including LAN, WLAN, Proxy, DSL, and different settings.
192.168.2.1

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.