WIZnet Developer Forum

No OTA mode after factory default

Dear Everibody!

I done a factory reset on WizFi250.
After I cant start OTA mode (from OTA cmd or from WEBS cmd or from HW pin).
Exactly say the 250 ack my OTA command but cant provide the OTA AP.
But WEBS mode (AP!), AP mode and wifi client mode are working.

My first ide was: during the factory reset 250 lost its MAC address.
I reprogramming it, but nothing changed.
250 OK my OTA request but not provide the AP.

Anybody have idea how can I recovery OTA mode after factory deafult?

For information the original firmware of 250 was 1.0.3.3 version.
The factory default was 1.0.3.3 version.
The highest firmware I tried (before factory reset) on was 1.0.5.2 beta.

I welcome any idea.

kzsolt2

Hi kzsolt2

could please check this article below? then try the OTA function with AT commands.
https://wizwiki.net/wiki/doku.php/products:wizfi250:wizfi250pg:start#wi-fi_ota_over_the_air_-_app

I guess removed MAC address is not important to work the module as a AP.

If you get response [OK] from “AT+FOTA” and “AT+WEBS” commands,
please check below command and response.

  1. “AT+MFDEF=FR”
  2. “AT+WANT=3”
  3. Connect to an AP as a station mode to check RF status.

Thanks.

Dear Daniel!

The OTA upgrade was worked fine on this module BEFORE the factory deafult beacuse in this way I upgrade FW from 1.0.3.3 to 1.0.5.2 before the factory reset.
The OTA upgrade work fine on all module EXCEPT on module where I done a factory reset.

The WEBS mode work well on all module INCLUDING module where I done a factory reset.

The AP and station mode work well on all module INCLUDING module where I done a factory reset.

The Antenna configuration is good idea.
Maybe the factroy reset set onto invalid value and my code does not set it in OTA mode (but set it in WEBS, AP and STA mode).
I check the related code.
But if tis why OTA not start from WEBS mode?

Best regards, kzsolt2

Dear Daniel!

I checked.
The driver force PCB antenna (what we use) before start OTA or WEBS mode.

Again. This factory reseted module can work in WEBS mode but not work in OTA fw upg mode even if OTA triggered from WEBS mode!

Best regards, kzsolt2

Hi

could you please let me know which commands you used and how the module replied?
did you used the Evaluation Board with WizFi250 or not?

Thanks

Dear Daniel!

We use wifi (and other communication) module of different vendor for our hardware.
Our own hardwer (and firmware) capable to handle them.
One of them are wizfi250.
We do not use (do not need) Evaluation Board.

“…how the module replied?”
We does not reply a WIZFI module. We just buy it.

"could you please let me know which commands you used… "
If you mean before OTA request then nothing.
We go to Webs mode using AT+FWEBS=1,A command. And then try to start OTA mode using web page of.
A result are same if we try to start OTA mode using AT+FOTA.
A result are same if we try set 250 using AT+WANT or AT+WREG or any other related set command, and then start OTA mode using AT+FOTA.
Again, this problem only occured on WIZFI250 which got factory default on 1.0.5.2 WIZ firmware!. All other instance wizfi250 are works fine.

We have two theory:
1). The downloadable 1.0.3.3 firmware not equal with factory default 1.0.3.3 firmware (e.g. last one is not capable to OTA).
2). Firmware 1.0.5.2 in some way change the flash content structure? or data? of 250’s module. The factory reset does not count with, and leave some stange data (e.g. OTA AP name) on its garbled content. This is why factory default 1.0.3.3 not capable to start OTA AP.

Best regards, kzsolt2

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.