WIZnet Developer Forum

Problem with order of serial commands

Hi,

I am still operating my device in AP Client Multibridge Mode. The modules firmware is the new 1.1.29 and meanwhile, I have got the impression, that there is a problem with the order, serial commands are given to the module.
I tested both, a variation of wait time during different commands for response as well as the wait time between commands itself.

The problem is, that we control the module via µC over serial interface and therefore need a stable communication between module and microcontroller.

At the moment I am commanding the following instructions in the following order:
, power setting, response
, Alias, response
, AP-SSID, response
, asking for channel, response
<PU5_3_0_0_123456789ab>, setting security, response
setting of radio on/off with the series:

<ORnvram_set CountryCode IE>
<ORnvram_set CountryRegion 1>
<ORnvram_set CountryRegionABand 1>

Every command with response

, SSID setting, response

I perform a for site survey followed by a <PIXNET39_123456789ab>
The response to this is <4>

I so far have not fully understood the mechanism for connection to an AP.
Under which conditions the <4> response is sent during command and when in general I need to send command ?

Could you please advise a specific order in using the above serial commands and if required is there a need for splitting the command series into pieces, maybe interrupted by additional reboot sequences.

Hi

I think that command’s response has some bug. Although command return <4> response, WizFi630’s operation is well.

If you want another command, refer to below.

If you want to use environment as below.


You have to use this command.

Hi,

the command is no option, because we work with fixed IP address.

Is there another workaround instead of using command ?

Hi

the command is no option, because we work with fixed IP address.

Is there another workaround instead of using command ?

Hi,

I thought the command is necessary in order to make a new AP known to the Wiznet module ?

Hi

command is not necessary in order to connect your AP and WizFi630(AP-Client Mode).

For connecting WizFi630(AP-Client Mode) to your AP, there are two method.

First Method

Second Method

Sorry but I Don ’ t understand.
You say there is no need for using PI command in order to connect module an AP but then you tell me, that the second method
to do so is PI command.
What exactly does the PI command perform ?
My experience to a brand new unknown AP was, that besides of the security settings, the module
somehow needs to get informed about the APs BSSID. With Web Access this could be performed by the connect action,
which filled this information into the Form.
So if there is a way to command the APs BSSID to The module it might be the easiest way to perform
a switchover from one AP to another ?

Hi

What exactly does the PI command perform ?

somehow needs to get informed about the APs BSSID. With Web Access this could be performed by the connect action,
which filled this information into the Form.

So if there is a way to command the APs BSSID to The module it might be the easiest way to perform
a switchover from one AP to another ?

Hi,

I have tested both solutions:

At first using the command for setting the modules security followed by command and command.
As stated before I get the <4> response for the command response, checking the web page, everything is fine, but no connect.

Using the second solution I at first apply the change in formerly stated commands(see former message), I perform and command followed by for flash. It is very strange, that as soon as I have to change the SSID via command, the response time for increases to several seconds. Then I perform command for reboot. After that, no connection again.

I check the web page of the module and every single setting has been assigned correctly.
BUT, the indicated MAC address of the AP(which is marked as optional) is still the one of the former assigned AP.
As soon as I apply the correct MAC address of the AP and perform ‘apply’ action the connection is established.
So the modules behaviour is exactly as I have expected all the time.

As your current solutions don’t work in anyway I urgently ask you for a working solution, as I have already spent over 2 weeks for exploring the circumstances around the modules configuration. :blush: :open_mouth: :cry:

To give you another help:
If I perform the manual action to alter the APs MAC address on the web page, the serial command interface returns the following string as a response to a cyclic request for the module status:
S1_iwconfig apcli0 | grep ESSID | cut -f2 -d" /
AP configuration.txt (2.5 KB)

Hi nils333

I am sorry for late reply and we did not provide clearly solution.
Our test team does test about issue for supporting clearly solution.

Do you wait some time into your busy schedule? We will try to support solution.

Thank you.

Hi,

I really appreciate your support, so please let me know, if I can support you with additional information in order to get this problem fixed.

Hi nils

Okay Thank you.
I will send fixed firmware or solution after modifying this problem.

Thank you.

Hi,

when do you think we can expect a solution for the problem ?

Hi nils

We finish to modify firmware of WizFi630 about command. So I send e-mail to you attached firmware
Please test using it.

Hello,

what exactly has been modified with regards to the PI command ?
My current problem with the switching between APs is still the same. I still cannot switch over and the solution for the problem(manually connecting via the web page ) is also my only current option ?

What do you think about this ?

Best regards
Nils

Hi

My test procedure is as below.

Is it different your test method? If No, I think that you need to check parameter of whether if same with authentication and encryption value of your AP.

For more detail information about command, refer to this document.
http://wiznet.co.kr/UpLoad_Files/ReferenceFiles/WizFi630_UG_Serial_Security_Configuration_V100E.pdf

Hi,

my procedure looks like the following:

<ORnvram_set CountryCode IE>
<ORnvram_set CountryRegion 1>
<ORnvram_set CountryRegionABand 1>
<PU5_2_0_0_1a3fklzL45rf2a>


<OR iwpriv ra0 set RadioOff 0>

here wait for 20seconds

to check for the existing networks

<PIXNET1_1a3fklzL45rf2a>
the commands response is but query to status of module stays always with .

When I change to another AP, do I have to apply new SSID via command.
I don’t see it in your test code.
I have to apply radio on/off command as well as country code as there are no commands to read them out, so I apply them every time.

Hi nils

In our test environment, It is well. I attach the recording video file in your mail when I did test. Please check your e-mail and show video file.

Test Scenario is as below.

  1. Factory Default ( Using command )
  2. Set your configuration such as , <OR….> ( Refer to video file )
  3. Associate to WiznetKaizen AP
  4. Switch AP to DIR-636L AP
  5. Switch again to WiznetKaizen AP

I think that you can input wrong parameter of command such as WPA2/AES, WPA2/TKIP.
So please check again that your AP’s security information and parameter is same.

Hi,
sorry for the delay, I have been out of the company for a week.
I tested very carefully again and the result is as follows:
First test I perform with a second WizFi630 module configured as an AP. This works together with the version 1.1.31 of the Client module.
The second AP is an older Linksys type Wireless-G Access Point WAP54G version 3.1 from Cisco Systems.
With this AP, I cannot perform the same procedure for connection, it doesn’t work. The status is always .
But if I perfom the connect procedure via the web server, everything is fine.
And again…the only difference I see before I perfom the web server connect is, that the web page still shows the MAC address of the former AP. After performing the web connect, the correct MAC adress shows up on the web page and the connection works.

The attached file needs to be attached to extention .tmf for use with terminal program you are using.
With this I always use macro order M4, M5, , M6 and macros M7, M8 and M9 in order to switch between APs with SSIDs mynet and XNET33, but as I sayd, it doesn’t work no matter what I try.
WiznetWifiMacros.txt (511 Bytes)

Hi,
after checking your sequenzes again I realized the difference in not resetting to factory defaults after firmware update, so I did it and the AP switching started to work.
As a new strange effect:
In the past I always had to send <+++> as the first command, by now I get the response <1> for that, so I can directly start with serial commands without switching to command mode(maybe this is intended by the new firmware ?).

WIth regards to the status message of the connection:
If I change the password either on the AP or the client side, the connection does no longer exist, but is still indicated in the status telegram with short interruptions.
I guess that this is the result of the client asking for a connection, hence exchanges the password and is then disconnected due to the wrong password.
So the status telegram cannot be used for evaluation of a 100% valid connection, because there is no difference between a bad connection and a wrong security setting with regards to the status telegram.

Is there any other possibility to validate the connection also from the application point of view ?

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.