WIZnet Developer Forum

WIZ550S2E F/W upload failure

Hi All,

I’m having problems uploading F/W to a WIZ550S2E EV board.

As far as I can check, all the tftp configuration on the server are correct, I tried with two different servers (one Mac and one Linux) and multiple clients. All is well except for the WIZ550S2E card.

Strange, since a few days ago I successfully upgraded F/W on another one, same configuration, no problems at all.

What happens is that when I hit the “F/W Uploading” button, a pop-up shows the tftp server parameters, I click OK but nothing happens.

In the other board, I recall a new pop-up showing up at this point.

I checked the log on the tftp server as well as wireshark sniffer traces. It looks like the board does not even try to connect to the server.

WIZ550S2E with F/W 1.0.3 onboard and Conf Tool 1.0.3

Maybe I’m missing something trivial here.

Help would be greatly appreciated,

Ezio

Hi Ezio,

Situation that you described is really strange.
Why don’t you try to upload F/W using Flash magic tool?
Check short guide on https://github.com/Wiznet/WIZ550S2E#firmware-download

Best regards,
Viktor

Hi Viktor,

Why don’t you try to upload F/W using Flash magic tool?

Well, I wouldn’t, for a number of reasons.

First off, the tool works on Windows, we don’t have a windows PC, we can choose either Linux or Mac … getting a Win PC for one upload is definitely an overkill.

Then, the procedure looks quite complex, if the F/W upload does not work with a fairy simple tool like the configuration tool, I worry that it will not work with a more complex procedure where a number of things can go wrong.

Next, our board is RS-485, not 232, does it work on 485 as well?

And last but not least, the configuration tool must work, I cannot understand why it is so complex/unreliable.

Looking forward for you excellent support,

 Ezio

Hi Ezio,

I agree with you, configuration tool must work. But in your case something is going wrong, either with hardware or with software.That’s why I propose to upload F/W using Flash magic tool.

There is version available for MAC (https://www.flashmagictool.com/download.html scroll till the end).

Generally before FW upload through TFTP board shall be factory reset. But factory reset doesn’t reset EEPROM. I would propose to you to erase and write EEPROM too using Flash magic tool.

I attach EEPROM for rewriting. Try following:

  1. Rewrite EEPROM using Flash magic
  2. Upload FW using Flash Magic
  3. Input MAC address
    EraseEEPROM.zip (15.0 KB)

I understand your reasons that you mentioned, but there is no other way to solve your issue.

Best regards,
Viktor

'morning Viktor and thank you for your reply.

Good to know we have a flash tool for Mac, I’ll give it a try.

One question tough, modern PCs (and especially Macs) don’t have a 232 port, I have Linux boxes with RS-232, but in any case, our EV is RS-485, can we use the same procedure?

Is a serial adapter like Moxa good for RS-485 uploading of the F/W?

In any case, this is what I did trying the upload http-colon-slash-slash-bbbsw.it/download/WIZ550S2E-FWupload.mov
Did I miss some crucial step?

You mentioned that before uploading, the board must be factory rest, that means that we can use only the factory default subnet 192.168.11.0/255 for tftp upload? I’ll try that also.

Cheers,

   Ezio

GEEEZZZZ!!!

It was my fault. In the F/W upload popup I was not entering the password … thought it was the tftp server password.

I input the board password and this time it worked.

It would not be a bad idea to alert the user of wrong/missing password, tough.

Sorry for the inconvenience,

Ezio

Hi Ezio,

Glad you solved it. We will consider your proposal regarding alert.
Should you have any questions, let us know anytime.

Best regards,
Viktor

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.