WIZnet Developer Forum

Data not corresponding

Hello, I have probleme getting the rigth data to be transmit. I am using a WIZ750SR-110 to convert RS232 data to Ethernet data. The data on the side of the serial interface are good, but not on the Ethernet side.

This is the data that my serial device send to the serial interface of the WIZ750SR-110.

Thanks in advance for your help.

This is the data that I get on the Ethernet side.

And This is my configuration on the WIZnet S2E configuration Tool.

Thanks in advance for your help.

Does any one have an idea how can I fixe it ?

Thing I have try :

  • I try with a second device, but only connect to my pc this time. I connect the Ethernet cable to my PC and with a USB to serial converter I connect the other end to my PC and commuinicate with terminal to transmit data. The problem is still there.

  • I also try to connect my module as a TCP client, but I was not able to get a TCP connection.

  • Downgrade the firmware to the 1.2.9 version and no different result so I came back to 1.3.3, but now I have problem to change setting with the config tool. It does not work any more. The setting does not take place.

It will be realy appraciate if someone can help me with my problem.

Hi

Can’t you see the data that’s being printed out from the terminal program?

If you can’t see it, there is Baudrate in Configuration Tool Serial Options.

Set Baudrate to 115200 and terminal program to 115200.

Thank you.

Hi Louis,

Thanks for your anwser, unfortunatly they are both set at 115200 and I still get the same problem. The output characters are not corresponding.

This is the configuration of my terminal and for the Wiz750SR-110, it is configure as default.

On the left is the data I expect to receive and on th right it is what I receive after the data pass over the Wiz750SR-110.

The default value of WIZ750SR-110 is 115200. It might have a different setting, so please use the Configuration Tool to change the baudrate.

Thank you.

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.