Setting Search Identification Code on a WIZ107SR

#1

I have a device with a W7100A chip on it which I can configure with the “WIZ107SR / WIZ108SR Configuration Tool” (so I guess it’s basically a WIZ107SR device on a custom PCB).

With the “WIZ107SR / WIZ108SR Configuration Tool” I can successfully configure everything, including the search identification code.

For production I want to have my own tool for configuring the WIZnet chip. I tried to send the following string via UDP broadcast to the device:
“MA\0\bܪ²\r\nPW \r\nIM1\r\nLI192.168.11.2\r\nSM255.255.255.0\r\nDG0\r\nBR8\r\nDB1\r\nPR0\r\nSB0\r\nFL2\r\nPT0\r\nPS0\r\nPD0\r\nTE0\r\nSPCCMMEI\r\nSV\r\nRT\r\n”

I can verify with the “WIZ107SR / WIZ108SR Configuration Tool” that all settings were written successfully, except for the search identification code. As you can see in the string above, I try to set it to “CCMMEI”, but when I read the configuration with the “WIZ107SR / WIZ108SR Configuration Tool” it is empty. What could be the problem here? Is there anything special I need to consider when setting the search identification code?

#2

Hi.

I think, try to packet capture and analysis using Wireshark program is good for you.
What is the difference between the two cases captured packets -your config tool and WIZ107SR config tool- is there?

#3

It works now! The problem was not with the SP setting itself, but with the PD setting.

I sent PD0 instead of PD00 which apparently messed up the rest of the string…