WIZnet Developer Forum

W5100S-EVB-Pico build error

Hello.

I’m trying to use W5100S-EVB-Pico in C-.
I followed “RP2040-HAT-C/getting_started.md at main · Wiznet/RP2040-HAT-C · GitHub” and downloaded your code and tried to build loopback project.

  1. download your sdk from git
  2. move to loopback folder in examples
  3. mkdir build
  4. cd build
  5. cmake …

and got error…even though I didn’t changed any…

I have installed pico sdk and it works with blink example on W5100S-EVB-Pico.
I haven’t changed any path after download your code.
Seems like a configuration issue but I couldn’t make it work.
Could you help to build loopback example?

cmake ..
CMake Warning (dev) in CMakeLists.txt:
  No project() command is present.  The top-level CMakeLists.txt file must
  contain a literal, direct call to the project() command.  Add a line of
  code such as

    project(ProjectName)

  near the top of the file, but after cmake_minimum_required().

  CMake is pretending there is a "project(Project)" command on the first
  line.
This warning is for project developers.  Use -Wno-dev to suppress it.

-- The C compiler identification is GNU 9.3.0
-- The CXX compiler identification is GNU 9.3.0
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
CMake Error at CMakeLists.txt:16 (pico_enable_stdio_usb):
  Unknown CMake command "pico_enable_stdio_usb".


CMake Warning (dev) in CMakeLists.txt:
  No cmake_minimum_required command is present.  A line of code such as

    cmake_minimum_required(VERSION 3.16)

  should be added at the top of the file.  The version specified may be lower
  if you wish to support older CMake versions for this project.  For more
  information run "cmake --help-policy CMP0000".
This warning is for project developers.  Use -Wno-dev to suppress it.

-- Configuring incomplete, errors occurred!

Hello,

Try building in the top-level directory(RP2040-HAT-C), not in the loopback example directory(RP2040-HAT-C/examples/loopback).

Thanks.

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.