W5200 link issues

Hope someone can give me a hint here. I am changing an existing design from w5100 to w5200 (I know this is not really sensible, but the w5200 is available to purchase from my supplier, all others, including w5100 have really long lead times).
I can talk to the w5200 via SPI, read/write regs no problem. Voltages look OK (3.23V, 1.9V), quartz looks OK. If I connect to my normal switch here in the office (1Gb port on a fritz box) PSTATUS is 0x07 or 0x17, so no link.
If I connect to a simple 5-port 10/100 Logilink switch and then to my main network PSTATUS is 0x27 or 0x37, so link up. At this point I can ping a bit:

Pinging 192.168.43.230 with 32 bytes of data:
Reply from 192.168.43.230: bytes=32 time=2ms TTL=128
Reply from 192.168.43.230: bytes=32 time=3ms TTL=128
Request timed out.
Request timed out.

I can occasionally access the small web server I have as a test application, usually I get “connection reset”. I have also used one of my original boards with the w5100 disabled and I have patched a w5200 Quick Connect board into my design and it works fine (so it looks like my code is OK). I am really unsure what to check from this point.

This is my circuit:

Any hints would be welcome.

Just a quick update, in case this jogs anyone’s memory. I discovered that when I plug my board into a different switch it seems to work, link is up directly after init, I can ping, etc. Sometimes I need to reset the board to get it into the ‘working’ mode, but once in it, it seems to stay that way. I then tried all switches I have available, got about 20% of them working OK with the board, 20% working a bit (link went up occasionally) and the rest, no function.
I also tried exchanging for a different transformer (now an RB1-125GAB1A bought from Wiznet’s shop), the board behaves in exactly the same way, so it’s not that. I have seen various posts referring to particular batches of the w5200 being flaky depending on the Switch used. My w5200 is stamped on the top with:
HHJ727
2109
What do these numbers mean? Is 2109, week 9 in 2021?
This is what my board looks like:

Anyone got any ideas?