W5500 / Atmega1284p 0.0.0.0 server address

Hi there, first of all I already checked posts with similar issues without successfully solving it.
So here I am, trying to run a Wiz850io for a chat server.

At first, I tried it with an Arduino Uno board, connecting ;
GND / VCC / MISO / MOSI / SCK / SS and RST pins, uploaded the ChatServer example running with Ethernet2 library. Everythings fine, I’m able to chat PC to Arduino

Then I just swith my connections cables to the Atmega1284p, I just power the Wiz850io through the uno board since it has a 3.3V regulator.
Uploading the same code
BUT, it only give me a 0.0.0.0 chat address, sometimes 255.255.255.255…

I can’t figure it out, can anybody help ? Maybe there is a special configuration to use SPI on the 1284p I don’t know at this point.

Thanks

To add more informations, I think I found the problem. I did burn a MightyCore Standard bootloader in my 1284p.
The pins are then differents than the Uno, so this could probably be fixed by burning a Bobuino version of MightyCore to match the pin out…
I’ll try this solution and update this post

I just solved my problem, it needed some modifications of w5500.h and Ethernet2.h files.
Switch CS pin definition from 10 to 4 :
w5500.h line 135
Ethernet2.h : lines 34-35

Good!

Yes, If you want to use the Arduino Ethernet example, you need to Define(set) the CS Pin.