No ping or connection after successful W5100 connection

The W5100 is powered up and the chip is initialized and the TCP/IP socket is in listening mode. Then a successful connection is done. It’s also possible to disconnect and reconnect again successfully.

Then W5100 is powered down and the same start-up sequence is repeated. It’s no longer possible to get e response from pinging and it’s not possible to connect. No power cycling will fix this. The client is running on a Windows 10 PC. If the Ethernet connection is moved to another Windows 10 PC, it’s still not possible to ping or connect. The error message while pinging is “Destination host unreachable”.

By waiting a couple of hours, a new power-up is done, and again it’s possible to reconnect to W5100 in listening mode.

How is it possible that W5100 is affected by how long it’s powered-down? Or what other things can be wrong?

I have now changed to an UDP socket instead.

The same problem occurs: UDP communication works and when I power-cycle the W5100 chip, the connection to the UDP socket is lost. Pinging is not working either.

Pinging has nothing to do with sockets, it is another part of the chip’s circuit/logic.

The possible causes are:

  1. there’s a problem in initialization code, low probability;
  2. chip’s driver performs some dynamic action (e.g. DHCP) and gets different properties (e.g. IP address) and of course you can not reach it at old IP address. After some time DHCP server forgets the lease and chip gets original IP address and is again available for you pings, low probability;
  3. intermediate device, e.g. router, sees port down and performs something cutting further communication for some time, and this is highly probable.

Connect device directly to your PC and check the behavior - if it gets link up, sends any packets (use Wireshark).

Thanks for answer. The cause of the issue is found.

There is an embedded switch between W5100 and the PC Ethernet port. The switch and W5100 was auto-negotiating the bit-rate (OPMODE2-0 pins set to 000). Between W5100 and the switch there was a capacitive PHY. The bit-rate negotiated was too fast for this. After setting OPMODE2-0 pins to 111 (Manual selection of 10 BASE-T HDX), the connection problem was solved.