WIZnet Developer Forum

220 제품에 대해서 문의 드립니다

  1. WizFi220에서 아래와같이 설정을하여 연결을 하였는데요
    AT+WWPA =tytt-4084791
    AT+NDHCP=0
    AT+NSET=192.168.1.55,255.255.255.0,192.168.1.1
    AT+WAUTO=0,iptime-ty,12
    AT+NAUTO=1,1,1900
    AT+DHCPSRVR=1’
    ATC1
    AT&W0
    AT&Y0
    ATA

이상태에서 연결이 잘되고 tcp통신까지 확인하였습니다.
그런데 디폴트 셋팅을 해서 전원을 껏다가 켜도 항상 위와 같은 설정이 디폴트되어 통신 상태가 유지되는데
AT COMMAND 상태로 돌아가기 위해서는 어떻게 해야하나요?
그리고 연결된 상태에서는 원래 커맨드가 안먹는건가요?
메시지를 보내지는것 외에는 할수 있는게 없네요…

  1. 일반 IPTIME 라우터로는 정상적인 연결과 통신을 했는데
    제 1차 목적은 통신사 포켓 라우터모듈을 가지고 LTE 통신망을 이용해 서로 데이터를 공유 하는겁니다.
    우선적으로 라우터에서 뿌리는 가상 IP를 이용해 ATA까지는 정상적으로 동작을 하나 PING 도 안먹고 라우터에서 IP할당을 안하더군요
    다시말하면
    AT+WWPA =12345678
    AT+NDHCP=0
    AT+NSET=192.168.3.5,255.255.255.0,192.168.3.1
    AT+WAUTO=0,TP-TY,10
    AT+NAUTO=1,1,51794
    ATA
    라고 입력했을때 정상적으로
    IP가 뜨고 통신 모드로 들어가는데 PING이 안되고 라우터가 IP할당을 안한다는거죠…
    서로 다른게 있는건지 그리고 어떻게 해야 서로 연결이되어 IPTIME을 가지고 통신한것처럼 되는건지
    그리고 LTE통신을 이용하기위해서는 어떠한 방식으로 AT COMMAND를 적용해야하는건지
    초짜라 아직 질문수준이 낮네요
    알려주시면 감사하겠습니다.

안녕하세요

  1. 접속 이후 AT Command를 입력하기 위해서는 Command mode로 전환해야 합니다.
    Programmers guide에서 Command mode와 Data mode를 찾아보시면 자세한 내용을 확인하실 수 있습니다.
    간략하게 말씀드리면,
    접속된 상태(Data mode)에서 +++ 을 입력하시거나, HW 트리거를 사용하시면 됩니다.

  2. 이 문제는 LTE 라우터의 문제인것 같습니다.
    LTE 라우터에 연결하기 위해서 usim 등의 별도의 인증 과정이 있을 수도 있습니다. 통신사 핸드폰이 아닌, 노트북 등의 범용 WiFi 단말로 우선 접속이 가능한지 테스트 해보아야 할 것 같습니다.

PC와 모바일에는 모두 연결되는것을 확인한 이후에 EVB와 연계를 시켰는데 IP 할당을 안하는 경우
지원 가능한 방법이 있을까요??

혹시 연락이 가능하다면 전화 통화 가능 하실까요?
whckden@naver.com 메일 부탁드리겠습니다.

안녕하세요

WizFi220을 DHCP로 IP를 할당 받아보시겠어요?

관련 AT 명령은 아래와 같습니다.

at+wd
at+ndhcp=1
at+wwpa=12345678
at+wa=TP-TY

혹시 DESTINATION PORT를 정확하게 알고자 할때 어떠한 방법이 좋은지 추천 해주실수 있을까요?

Destination Port라면 접속하고자 하는 TCP 서버의 포트 번호를 말씀하시는 것인가요?

그렇다면, 알 수 있는 방법은 따로 없습니다.

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.