Data packing


#1

I’ve currently got a WIZ140SR module set up with 1.6.1 firmware, data packing character = 00, size = 0, and time = 0. I would have thought this configuration would not do any data packing, i.e. type one character and it goes in its own packet. This is not what I see, though. I I open a telnet session to the terminal server, type a line followed by a , and only then do I see the characters come out the serial port. I need the terminal server set up to pass characters on as soon as they are received from the network side.

I’m sure this is not a byproduct of the telnet software, since it works as expected when I replace the Wiznet module with a Cisco terminal server.


#2

If you set data packing character = 00, size = 0, and time = 0, packing condition is not applied and any serial data sent to the Ethernet when it comes as you mentioned.

In my test, whenever I type the character in Win7 telnet session, the character is transferred to the serial so I’d like to know what kind of telnet program do you use.


#3

Unfortunately, this does not appear to be true. As I said in my previous message, I do have all data packing fields set to 0, but I don’t see any characters come out the serial side until I send a character. I can send you logic analyzer traces clearly showing this if necessary. posting.php?mode=reply&f=21&t=582#

Good to know my interpretation of you scant outdated documentation is correct, but in practice I don’t see it work that way.

Gary


#4

BTW, I’m using a standard Linux telnet. It works fine through a Cisco, Black Box, or Digi terminal server. In fact, the only terminal server I’ve found that DOESN’T send one character at a time is yours :^(

Just did a little more snooping, and it looks like “character” vs “Line” mode is negotiated between the two ends when setting up a telnet session, with the default being “line” mode. Looks like I may need to force “character” mode for your terminal server, where most others seem to negotiate to “character” mode. I may need to play around with the telnet options a little more.

Gary


#5

Did some testing, and it looks like if I change the telnet connection to “character” mode, everything works like I want. Bothers me a little that this isn’t automatic on the Wiznet terminal server while it is on all the others I’ve tried. This means I need to establish a telnet session, escape to the telnet prompt, issue a telnet mode command, and then resume.

We’ve got over 300 modules up and running here. Any chance Wiznet would do a firmware build that forced character mode?

Gary


#6

It’s good to hear you find the cause of this issue and I googled and found below.

Do you want our module operate like character mode regardless of telnet client’s setting?
As you may know our module is general purpose Serial to Ethernet gateway and currently there is no special feature for terminal server.
I think we need to study how to force the telnet client into character mode.

JB