WIZnet Developer Forum

DHCP connection fails when using internal corparate network.

Hi,

I am working with W7500S2E-R1 modem. When the modem is connected to the public network the communication to a server(with public IP) is successful. Whereas, when the modem is connected to an internal corporate network, the server communication fails as no response comes back from the server. Why is this behavior?

Another question, I want to know what is the correct way to get the DHCP address. Are there any pre-configurations or any configurable controls around DHCP? The way I followed is, I used to enable the DHCP by setting AT+IP_MODE=1. And then I try to retrieve assigned IP address using AT+IP?. Please confirm this is the right method.

Thanks

About connection
If you use the public ip, you can’t access the external server. Therefore you should use the DHCP for IP obtain.

About DHCP
You can set up the configuration data via configuration tool.
https://www.wizse.com/w7500s2e/# ->Please Download the Configuration tool ( WIZS2E ConfigTool V1.0.1.4 )
Also you can modify the IP configuration mode. After AT command mode finished, you should use the EXIT command(AT+EXIT). AT+EXIT command will save the current settings.

Hi,

Thanks for the reply.

I always enable the DHCP connection to obtain the IP for both when I use the corporate network or external network. The issue is TCP communication is working fine when it is connected to the external public network. But when the modem is connected to the internal corporate network, the communication fails. It can talks to internal server within the same internal network but not to an external server.

Please reply.

Okey,I’ll wait for the response.

Hi,

Yesterday we tried to connect to a server 91.197.93.230 using the 443 with 3 kinds of network configurations. This is an SSL server. (We have our own SSL stack to connect with SSL servers which is working well with other modems without any issue. )

After configuring the Modem, the TCP connection has been established to the server successfully in all the 3 cases, that we confirmed with the Wireshark log. Then we attempted to send an SSL - Client Hello packet through Wiznet. We expect a Server Hello response back to Wiznet, but we dint get any response if we connect through Corporate LAN with DHCP. For the other 2 cases we got a response back and working. So we used an oscilloscope (Picoscope) between our device and the Modem to test whether the packet we sent to Wiznet is reaching the Wiznet. I could see the packet is reaching the wiznet, but the wireshark log doesn’t capture any packet coming out from the Wiznet.

1. Corporate LAN with DHCP - not working
2. Corporate LAN with static IP - working
3. LAN Router with DHCP - working

I have attached the Logs for all the 3 network configurations that includes the device log capturing the activities of modem configuration and packet sending & reception, wireshark logs and the Picoscope log for the non-working case.

CorporateLAN-DHCP.zip (195.2 KB) CorporateLAN-Static_IP.zip (14.8 KB) Lan-Router-DHCP.zip (13.1 KB)

If you get the IP using DHCP Server and the network is not the same, the destination address should be the gateway address.
In case of num1(Corporate LAN with DHCP), I think the destination address is not the gate address.
Also, When it set up the DHCP using configuration tool, try to test again using PC ping command.

Hi,

I see a strange behaviour with Wiznet when connected to Corporate network in assigning the network IPs.
When i powerup the module, in a serial terminal i could see the Module initialised with DHCP, Mac address & network IPs assigned. Initially it assign the IP address as below,

IP: 10.2.2.75
SN: 255.255.252.0
GW: 10.2.1.1
DNS: 10.2.1.4

Which is correct. Our Gateway is 10.2.1.1 & our DNS address is 10.2.1.4. And again in next line, i get another set of IPs,

IP: 10.2.2.75
SN: 255.255.252.0
GW: 10.0.0.1
DNS: 195.110.64.205

where the gateway address & the DNS is seems to be not correct. Unfortunately the second set of IP configurations are set in the module. And i fear this might be the reason why we couldn’t connect an external IP from corporate network. Please see the terminal screenshot here

.

We compared the DHCP behaviour with public network. The wiznet assigns IP only once & that seems to be correct. Attached the screenshot.

Could you please explain why the IPs are assigned twice when connected to Corporate LAN? Why wrong values are assigned to the GW & DNS?

If there are multiple DHCP Servers, it is possible to receive IP of twice at the same time.
Is the second assigned DHCP server not able to access the external network?

Hi,

Thank you for you reply.

Yes we have 2 DHCP servers but i am not sure the second DHCP server is connected to external network. I will ask our IT team and will let you know.

Hi,

We have 2 DHCP servers connected to our corporate LAN, which is supposed to be a single DHCP server. One of the DHCP server is mistakenly connected to our network. Once we disconnected the server, now only single set of network configuration is assigned to the Wiznet and the packets are going through without any issues.

Now that we solved the issue, my doubt is how a Wiznet behave when there is multiple DHCP servers connected to the network? Even if multi-DHCP servers are connected, i assume, the Netwok configurations are obtained from a single DHCP server. If so, how it chooses the DHCP server ? Does it assign Network configuration from very recent DHCP server it communicates?

Please reply

It works by DHCP Protocol.
If there are multiple DHCP servers, the IP of the DHCP server that responds to Discover is assigned first.

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.