WIZnet Developer Forum

unable to read identification register of W5300

Hi
I am interfacing Nucleo-L496 (STM32) with Wiz830MJ.
I am having a working experience with WizNM7010 for our older designs.

I have connected Wiz830MJ with Nucleo board using jumpers. As a first step I was trying to read IDR just to make sure connectivity is proper.

I have downloaded the library files for W5300 from github as per the link from wiznet website. I have also modified wizchip_conf.h as follows:

  1. #define WIZCHIP W5300
    2.#define WIZCHIP_IO_MODE WIZCHIP_IO_MODE_BUS_DIR
  2. #define WIZCHIP_IO_BUS_WIDTH 16
  3. #define WIZCHIP_IO_BASE 0x60000000

I tried uploading my wizchip_conf.h but could not do so. Anyways I have done all “@todo” changes except reg_wizchip_cris_cbfunc, reg_wizchip_cs_cbfunc, reg_wizchip_bus_cbfunc.

The issue is that I am unable to read IDR successfully using WIZCHIP_READ (0x600000FE). I also tried wizchip_bus_readdata(0x600000FE).

I have doubly checked the jumper settings and also verified the CS & RD signals and one of the address lines using oscilloscope. These screenshots are attached for reference.

Kindly help me to proceed further.

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.