[From QnA]WIZ812MJ Startup Status


#1

I had used WIZ7010B in past and now trying with WIZ812MJ and having some problems

  1. What is the LEDs status if I just connect the Power pins of the module (Will both be ON ?)
    2)What is the maximum (or minimum) data rate for SPI communication to these modules ?

I am trying to write/ and read back few registers to ensure that I have setup proper communication to the module, but I am getting some strange response. (All Registers appears to be 0xFF)

So I wrote a loop to read 0x15 registers in a sequence (from 0x0000 to 0x0015) the result I got was register 0x0000 was 0x00 and rest of them were 0xFF.
I changed the direction of reading ( from 0x0015 to 0x0000) so now result is changed 0x0015 is giving me 0x00 and rest of them are giving me 0xFF.

Is there any other way I can be sure that my communication to the module is OK ?

I am using Silicon Labs C8051F340 to communicate with the module. I had tried with 3000 bit rate to 10000 bit rate but same result.

Can you suggest anything ?

I had connected only 10 pins of the module and rest of them are floating. ( I am currently testing it on my proto board and will pull up/down the remaining pins in my final design)
These 10 pins are
J1

  1. MOSI
    2 ) MISO
  2. GND
  3. 3.3V

J2

  1. 3.3V
  2. RESET
  3. SCK
  4. SCS
  5. INT
  6. GND

I am not connecting any ethernet cable to it right now, and still my module is getting slight warm


#2

Let me put it this way, I am following iEthernet bootcamp for my project and my program’s failing when I do the following:
//SOCKET INTI******************************************************
do{
wr_wiz_reg(Sn_MR_UDP,Sn_MR(0)) //protocol = UDP
wr_wiz_reg(0x00,Sn_PORT0(0)) //well-known ECHO port
wr_wiz_reg(0x07,Sn_PORT1(0))
wr_wiz_reg(Sn_CR_OPEN,Sn_CR(0)) //give the open command
if(rd_wiz_reg(Sn_SR(0)) != SOCK_UDP) //wait for the socket to come online
wr_wiz_reg(Sn_CR_CLOSE,Sn_CR(0))
}while(rd_wiz_reg(Sn_SR(0)) != SOCK_UDP)

My Sn_SR(0) is always showing 0x00 instead of SOCK_UDP. Ping works though.


#3
  1. Why my chip gets warm if no ethernet cable is connected to it ?

  2. I am using TCP mode to communicate with the chip. I am using socket 0 for this communication and facing an issue. I connect to the WIZ812MJ via hyper terminal, and I am successfully able to establish the connection. If I close the connection from terminal, I get the interrupt of close and everything goes fine…

If my network connection gets interrupted ( if i turn the network switch off or disconnect the cable from my PC), I dont get any disconnect interrupt on the module, furthermore, I tried to solve this issue by timely checking the Socket status register, and I found that it is giving me 0x17 ( SOCK_ESTABLISHED ) status. If I try to connect back from my PC, I can not get connected cause my SOCK is not in listening mode, and module is not able to detect that my previous connection was disconnected.

How to check for this scenario ?


#4

Hello,

  1. Please refering the W5100 operating temperature on our datasheet. It has some heat for operation.
  2. That case, the W5100 cannot recognize terminating the connection. Even any other device also cannot recognize it. That is why we use “keep alive packet”.
    Thanks.