connecting the wiz750sr-ttl ethernet module to arduino

i am trying to connect the arduino uno to the wiz750sr-ttl ethernet module and i was wondering if there is anything i need to do to the data on the arduino side before it gets sent to the module? or can i simply connect to the serial port and send the data through the serial.print() function?

Simply connect to the serial port and set the serial baud rate of Arduino Uno and WIZ750SR-TTL to the same value. The default baud rate for WIZ750SR-TTL is 115200 bps.
By configuring both devices with the same baud rate, the data generated by Arduino will be transmitted to the WIZ750SR-TTL module using the Serial.print() function.

i was able to connect the arduino and the wiz750sr-ttl and send data through, i am using the python socket function to get the data but when i read it i get a different value

heres my python code
#! python3

import socket
import sys
import struct
import codecs

HOST = “” # Standard loopback interface address (localhost)
PORT = 27 # Port to listen on (non-privileged ports are > 1023)

class H2S_driver():

def __init__(self):
    self.driver = socket.socket()
    self.driver.setsockopt(socket.IPPROTO_TCP, socket.TCP_NODELAY, 1)

        print("Connected at " + HOST)  
    except socket.error:
        sys.stderr.write('Time Out during TCP socket initial connection. Please check ethernet connection')

    while True:
        buffer = b""
        num_bytes = 4
        for i in range(num_bytes):
            data = self.driver.recv(1)
            #print(codecs.encode(data, 'hex'))
            buffer += data
        unpacked_data = struct.unpack('i', buffer)

if name == ‘main’:
when i send 0x14 from the arduino i get \xb3V\xeb\x00 in the python terminal. i was wondering what i am doing wrong? is there something i am missing when trying to read it in python?

Do you mean this following case?
arduino[0x14] <-(serial)-> wiz750sr-ttl <-(eth)-> PC python terminal[\xb3V\xeb\x00]

If it is right, I think we need to check the contents below.

  1. Does the serial data output well at 0x14 using Arduino and the serial test program (ex) TeraTerm, Putty, etc…)
  2. If the above is confirmed, whether the ethernet data is output well at 0x14 from the wiz750sr module through Wireshark

when i switched the module used it worked fine, the previous module i had found in an old project so i think is was either configured or was just malfunctioning

so i got it working correctly on one computer but then when i tried to use a different computer with the same python code and the same module i cant seem to connect to the module, the one i was using first that i got it to work on was windows and the other one is using ubuntu. i was wondering if there are any drivers or software that i would need to download to make it work?

You don’t need any specific drivers to connect the module to the Ubuntu PC.
Regarding your Python program, I regret to inform you that I can’t offer direct assistance. However, I recommend checking if the Python version installed on your Ubuntu PC matches the version specified in your program (python3). Additionally, ensure that the IP address on your Ubuntu PC is consistent.