Can't start anymore a TCP server!

Dear all,

i work on my application since many months.
today, i’m facing on a strange problem … : all communication between my CPU and the WIZFI250 module seem working as expected.

i join my AP without problem but when i try to start a TCP server with the “AT+SCON=O,TSN,80,0” command, it’s not working anymore !
no really big modification on my software, on these functions, since many time …

what i notice when i spy on the UART lines, is that :

on my board : after send the AT+SCON command, i receive the echo back correctly, then about 100ms later a “[OK]” … then nothing else …

on my EVB board, after send the AT+SCON command, i see the echo back, then some sec later, the “[LISTEN 0]” reply indicate that the socket 0 is open, then the [OK] !!

again, this functionality on my application was working perfectly since many weeks !.. suddenly, since 2 days, it fail …

i use the fw on my application board and my EVB.

i already try to factory reset the module (back to then burn the last fiwrmware

thanks for any suggestions… regards

strange …
[ul]factory reset to, then back to : not working as expected
factory reset to, then back to : working as expected ![/ul]

not sure what can be the/my problem … :frowning:



[Listen x] message is displayed on above F/W.
It is just displayed for mbed system.
If you don’t want to display this message.
You have to add the AT command like below.



please read carrefuly the question !

what i expect to know is “is there any think than can block a module to not send the [LISTEN or [CONNECT message”
(of course, when AP is working right !)

why i receive it with my EVB, but not with my real board !?.. i do something wrong, because before all was working !
but what !?..



well about your answer …

if i check all my previous backup (i started this project since 4 months, with fw ONLY ),
when i started the TCP server, with “AT+SCON=O,TSN,80,0”, i was already listen for the reply [LISTEN…] before the [OK] of the command !!
i used this reply to know the socket number of the TCP server !

what i see with the fw, is that [LISTEN…] is replaced by [CONNECT…]

so for what i know, [LISTEN…] is available since at least fw !..
i’m wrong somewhere ?

but now, i take back my EVB, flash the fw, then manually start the TCP server …
and i don’t see anymore the [LISTEN…] !!!

i think i become crazy …

thanks, regards


The ‘OFFICIAL’ doesn’t have that function.
I guess it is because the Event message is made again from F/W that has been deleted from F/W.

You can see the [LISTEN x] message when you use F/W.
Then you have to check the message format like below.

AT+MEVTMSG=1 //type this command [OK] AT+MEVTFORM=? //type this command and check answer "1111111111". 1111111111 [OK] … t_mevtform

well unlucky again :frowning:

personal board, fw

all work great until join the AP. the module is right associated to the AP, with the right IP.
from my computer, a PING to this IP work.

but when i try to start a TCP server socket by “AT+SCON=O,TSN,80,0”, i only receive the echo then the [OK] answers …
noway, can’t see the [LISTENx] message !!!

i’m totaly crazy since several days !!.. i have several new boards, and ALL show me this problem …
last week, that was working as expected !..
what i missing or doing wrong ??

module is setting with “default factory parameters”,
then UART handshake enable : AT+USET=115200,N,8,1,HW
then event message setting : AT+MEVTFORM=1111111111

please … suggestions ?
thanks, regards


[Listen x] message is displayed on above F/W.
It is just displayed for mbed system.
If you don’t want to display this message.
You have to add the AT command like below.


believe me … or not …
but i have do with my logic analyzer, a trace starting from RESET, up to open TCP server socket …
this trace show clearly
after RESET : version

and after AT+SCON : [LISTEN0] message !!!

i have done several firmware switch and factory restore on these modules … maybe something is wrong during fw change …
but as i see, [LISTEN is present on this module which show fw version !!

how can it be possible !?


well next of the story …

it seem that the modules are not happy when we do several fw change …
i have a total of 7 boards.

on 4 i have played lot of time and do several fw update … from; and
then after some time, these boards don’t work as expected … always a problem
even a factory recovery and/or factory setting … then a fresh update, the module don’t work exactly as a fresh new module !!

on the 3 new board, never fw upgraded :
i start the board the immediately update to
then all work perfectly !


Hi, phil

[Listen x] message for mbed can be displayed after added at command below on F/W.

It means that “mbed event message” will be enabled.

The default setting is the “disabled”.

Wizdaniel …

the screen copy i provide, comes from the SAME logic analyzer capture !..
first pic show version … then later, the [LISTEN 0] answer …

after playing a lot with all my boardw, i have 3 boards now that show fw version and NO [LISTEN message after open TCP socket server.
yes i already set the right “AT+MEVTMSG=1111111111” command !

on these 3 last boards, can’t successful recovery factory back then OTA to !



2 commands are necessary.



But as i know, you just type one command “at+mevtform”.

And, For upgrading firmware.

Please use the WIZSmartScript and write APP+DCT(refer to the wiki guide).
Then, try again.

The OTA mode can access external memory and get the firmware(saved) from external memory in WizFi250.
Maybe in your case, external memory is empty.

i set

and just try to add AT+MEVTMSG=1 (which is not documented in the wiki ???)
that change nothing : after the “AT+SCON=O,TSN,80,0” i only receive [OK], no [LISTEN x] !!

start WIZFI250_MPROF() :VG
WaitOK RCV : +WSET=0,test,0
WaitOK RCV : +WSEC=0,WPA2AES,12345645
WaitOK RCV : +WNET=1,,,
WaitOK RCV : +SCON=O,TSN,0,5000,1
WaitOK RCV : +SFORM=111111111,7b,2c,7d,0d,0a
WaitOK RCV : +MMSG=2
WaitOK RCV : +MMAC=00:08:DC:1E:XX:XX
WaitOK RCV : +USET=115200,N,8,1,HW
WaitOK RCV : +FGPIO={1,1,3,0},{1,5,3,0},{1,6,3,0},{1,7,3,0},{1,8,3,0}
WIZFI250_WaitOK : [OK] find

i can’t use WIZSmartScript , my module is the -CON version directly soldered on my board.

what does it mean exactly ?



External flash memory and Internal flash memory have each firmware. In some cases, the two have different firmware.
WizFi250 can be operated using the firmware in “internal flash”.

I think [Listen x] problem is that the firmware configuration mismatched.
It means DCT(raw firmware) configuration and APP(set from you) configuration have different configuration.
This case can appear when some user updates either APP or DCT.(different version).
So, i prefer to try “FACTORY DEFAULT Function” using AT Command below on WizFi250 ( F/W, appeared reply [Listen x]).
This command can synchronize with DCT and OTA configuration.

Unfortunately, It is sure that F/W of WizFi250 can display a [Listen x]. F/W need to use factory default function as i said.
I suppose that [Listen x] reply is not displayed after Factory default.

Would you please tell me “Boot pin” is available on your board?
If possible, you can use WIZSmartScript and update firmware other version.
Or, Update firmware DCT and APP ( F/W) using OTA (be careful).

AT+MEVTMSG command has recently been added to WizFi250 F/W.
So, I omit to document this command. I will document this command on wizwiki.



I tried to make your configuration like DCT and APP.
But, the situation did not occur. [Listen x] message does not display.

For printing a message of socket status like [Listen x].
You must install the firmware.

And AT+MEVTMSG document was updated in wizwiki site.


i’m surprise as you !
but i can guaranty that the fw is and i see the [LISTEN 0] message after running the TCP server !!!

my module is unique in the world !.. want to buy it for investigation ? :astonished:)

how send you a text trace from my terminal… with some “highlighted proof” ?
message me your private email please ?



A reply message was sent to your email.