WIZnet Developer Forum

W7100A-S2E not found on TCP-IP

Dear support,
we have been using the W7100A-S2E chip on a custom board since 2015 without any problem. Suddenly we’re now experiencing a weird behaviour on the last 10 boards manufactured 2 months ago. No hardware modifications have been done on the boards, but only 2 out of 10 work fine and they’re correctly detected on TCP-IP in a few seconds. With the remaining 8 boards we need to wait 32 seconds before they can be detected by the configuration tool; if we try to search before that time span the board is not found. All 10 chips used are marked as follows:
W7100A-64QFN
N7HW7-A11
1244
Futhermore, the 2 working chip do not comunicate anything over the COM port at power-up, whereas the 8 mis-working chips send information about Firmware version (4.0.5), MACADDRESS, GW,SN,IP.
Do you have any idea about the cause of this problem?
Thank You

hello, electros

thank you for your question.

Now, we are concerned about this issue.

Sooner or later, we will support you with it.

So sorry about that I could not solve clearly.

thank you,

lawrence

Dear electros,
I recommend you to try the firmware update as the first way to solve the problem.
I attach the W7100A-S2E-64QFN latest firmware - version 4.06 - for you.

W7100A-S2E-QFN64_v4_06.zip (21.9 KB)
Note) Attached application firmware binary is dedicated to the 64QFN package chips.

Please perform (1) firmware update and (2) search + factory reset of the device and report the result to us.
I hope you to solve the problem quickly.

Regards,
Eric

Dear electros,
I will add additional information for you.

All our W7100A series package chips are MSL 3 (Moisture Sensitivity Level).
The meaning of this is the description of the attached image, and baking before board mounting is required after a long time has elapsed since the vacuum packaging of the chip was unpacked.


Regards,
Eric

Thank you Eric,
I am a colleague of electros.
we will try with the firmware for the 64QFN package as soon as possible. In our country now is holiday and the factory is closed.
We will report the result next week.

At the moment I’m at home and I have only an electronic board with the W7100A-64QFN chip (not the s2e version).
I tried to install the firmware with WizISP in this card but it doesn’t work.
Next week we will try to install it with Configuration Tool by Ethernet in the cards with W7100A-64QFN-s2e chip version

Best regards

Dear fsisma,

Our W7100A-S2E firmware of the product consists of two parts(Application boot part and app part), only the app part is released (60kB size). Released firmware at website is used for firmware update using configuration tool only.

If the mentioned issue is not resolved by a firmware update, it may be a problem by moisture depending on storage.

Please try to chip baking before mounting and tell us your hardware production results.

Regards,
Eric

Dear Eric,
I’m glad to inform you that the firmware 4.06 you provided us has solved the problem. Now all the ‘faulty’ boards are immediately detected by the config tool and work correctly.
Thank You very much, I really appreciate your help!

Electros

1 Like

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.