WIZ550io and Arduino UNO R3


#1

I connected my WIZ550io to the Arduino R3 by hard wiring:

UNO–WIZ550io

GND–GND
MOSI–MOSI
MISO–MISO
SCK–SCK
SS–SCSn
RESET–RESETn
3.3V–3.3V

I made the changes in the Ethernet library for Arduino 1.0.5 as given on the Wiznet instruction page.

I can ping the WIZ550io from a Linux (Debian) Network tools screen through an ethernet switch (small dedicated network).

When I try to get a Webserver Sketch running on the Uno R3, it compiles and loads. When I send an ethernet address (192.128.1.2) to the Uno from the Linux PC (this is the address that pings from Linux) I get a message saying that “192.168.1.2 refused the connection.”

Any thoughts?


#2

Hi,

This means TCP Connection could not be established.

  1. Could you capture packets by using wireshark?

  2. Would you upload your code modified ?

Thanks,


#3

I’ve got a better idea. Send me Arduino IDE software with the proper Ethernet and SPI libraries installed and I’ll try that. This was supposed to work out of the box. I’m sure you have what I need, one that has been tried and works.


#4

Perhaps you could post it on the Wiznet site for all of us to use. There seem to be a few users that have this issue.


#5

I tried reloading the Wiznet Ethernet Library and got the Webserver sketch to work using the ioShield-A


#6

I got this to work satisfactorily, both with the ioShield A and a direct wire connection. Part of the trick seems to be, when you substitute the new Ethernet Library for Wiznet for the standard Arduino R3 library is to copy the new directory over the old one, and choose “copy and replace” (Windows 7) every time that dialog box pops up. I could upload the Arduino IDE I used for others if someone would let me know where that location would be on the Wiznet site.


#7

Hi,

You didn’t connect the WIZ550io INT and RDY pins?