Arduino Micro and 550io problems

#1

WizNet 550io and OLED webserver.txt (7.83 KB)Hi
I am having strange problems with the WizNet 550io module and a Arduino Micro.
I installed the latest WizNet library, replacing the default.

For example. I am trying to get the Ethernet Webserver example to work.
Serial reports IP address as 0.0.0.0, but the default is pingable but No web response.

I have also modified the example and using a Display, I monitor the localIP and it appears to jump around randomly!
I have taken this same code (only editing the utility file) and compiled it for a Arduino Uno with the Ethernet Shield ( I think its a WizNet 5200…) and it worked perfectly.

I have aversion 1.0 WizNet Module and tried different Arduino Micros.

The OLDE display is a 96x128 from Adafruit, using different pins and not SS, MOSI, MISO or SCLK - as for the WizNet.

I have attached the code:

Any advice greatly appreciated.

#2

I couldn’t open the source code with Arduino IDE and there is some files are missing.
Please send me the all the code to compile it. i.e. Adafruit_SSD1306.h library…

#3

Here it is
Libs.zip (124 KB)

#4

Dear All

I would greatly appreciate if anyone can confirm or tell me what Im doing wrong.
I have seen a few other people having similar issues but not a solution yet. This is my first WizNet product but being stuck like this will soon force me to look at an alternative controller and module combo for my project.

Rename the attached file to .ino
WizNet 550io and OLED webserver.txt (7.83 KB)