WIZnet Developer Forum

WIZ107SR socket disconnects and reconnects rapidly

Hi,
We use the Wiz107SR serial to Ethernet part in equipment we build. The typical communications process is to locate the our head-end equipment with the Wiz107SR at some remote location and establish a tcp/ip socket connection to a server and constantly communicate. The maximum time between either normal communications or heartbeat is 12-seconds. This connection needs to be persistent and most of the time it is.

    We have noticed that lately while using the latest 4.05 Wiz107SR firmware we experience the Wiznet socket disconnecting and re-connecting rapidly when the Network setting have DHCP selected.  If we change (where possible) to a fixed IP address the Wiz107SR behaves normally (no disconnect and re-connecting sockets).  

    We rely on DHCP for most of our installations since this is by far the simplest connection process for most IT departments where our equipment is located.  

    Has anyone else experienced this behavior?  It seems to be only after upgrading to Version 4.05 which was necessary because we were previous experience the FF:FF:FF:FF:FF:FF MAC Address problem.  Is there an upgrade or fix for this?

Thanks, Ron Hill

Hi, Ron.
If the network device that IP assigned by DHCP server, it needs IP leased time extension or reallocation (to perform renew operations) when the IP lease time has elapsed. ((IP leased time / 2) elapsed)

The WIZ107SR device performs a save and then reboot when IP re-assigned / IP lease time extended.
This is not an error.

Note that, If the product is operating as TCP client mode, It performed automatically reconnect after TCP connection disconnect / device reboot.

Eric,
The problem is not with the DHCP server. I have multiple systems using the WIZ107SR connected to the same network switch and using the same DHCP server but some parts disconnect and reconnect every few seconds without ever obtaining a new IP address or lease. We operate with the systems continuously connected to a Node server via a TCP/IP Socket. Most of the WIZ107SR parts function properly as TCP Clients using DHCP mode. However, We now several installations that rapidly disconnect and then reconnect to a socket on the Node server if they are configured to up DHCP mode. If those same WIZ107SR devices are configured to use a Fixed IP address they connect to the Node server and function properly.

    I have tried downgrading the firmware to version 4.04 but that does not change the behavior of the devices.  I have tried re-flashing the 4.05 version firmware but that also had no effect.  I currently have 6 or more devices that exhibit this behavior.  I can not verify if these devices functioned properly and then started the disconnect/connect behavior or if they always behaved this way.  

    Has anyone else experience this with the WIZ107SR?  Is there any fix for this?

Thanks, Ron

We have found a solution to our Wiznet WIZ107SR problems… we are switching to the Lantronix Xport-05. Simple to use and you can actually talk to a real FAE whenever you want and get immediate answers to questions. The integration process only took about 2-week (including the development of daughter board for a drop in replacement for the WIZ107SR). Check it out.

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.