WIZnet Developer Forum

W5500 LINK LED is always ON without even connecting the LAN Cable

Hi,

I am making a custom board using w5500, schematics referred from, wizwiki.net/wiki/lib/exe/fetch.p … 150406.pdf

Now I have tried several boards with my design and they seem to be not working for me. I just power up the device, and I see LINK LED is always ON.
I compare with shopwiznet.com/wiz850io board, and when I just power it up, LINK LED is OFF, and then I connect to LAPTOP using LAN cable, link LED is ON and being detected by laptop.

Where as in my custom board, link LED is always ON and after I connect to laptop, laptop displays cable disconnected.

I am sharing my schematic. Please help.

I had missed pullup for RSTN pin. Later I have 10K pull up in place. Still the same problem persists.

Please help.
Regards,
Girisha.

Unable to attach schematics. I am getting HTTP ERROR.

It is low probability that you have link LED’s pin connected to the chip shorted to ground, but anyway it is good to check to prove it is not the case.
As another device does not see the link most probably you made a mistake in your circuit and chip thinks that there’s a link. For example, connected transformer/jack incorrectly, or constructed loopback between TX and RX lines.

Upload it to some picture or file sharing site, along with photo of your board, and put links here.

Hi,

Thanks for the quick reply.

Here is the link for my schematic.

jmp.sh/v/JGxdXS4KqZ5cNIHc5B1P

Please check and let me know.

Regards,
Girisha.

Reference schematic is having 82 Ohms pull-down resistors on RXN and RXP lines.
Jack seems to be suitable and connected ok. Try replacing abovementioned resistor with those recommended on the reference schematic.

Girisha,

I noticed a subtle difference with your schematic and the reference schematic that perhaps could lead to a mistake in parts placement (especially if you are prototyping this circuit).

The pull-ups R2/R3 and center-tap R’s R10/R11 are on opposite sides of their respective 0-ohm damping resistors. Strange voltage divisions are possible if the damping R’s are changed from 0, or if the resistors are placed in the wrong spot.

Perhaps not the cause of your problem, but an inconsistency.

The schematic here:
http://wizwiki.net/wiki/lib/exe/fetch.php?media=products:w5500:w5500-ref-rj45with20150406.pdf
works well for me.

Regards,

-Chris
(Edit: Changed link to point at the actual ref schematic…)

Hi Eugeny,

Thanks for your input. The reference schematic that I am using has 49R9 resistance. But I will give a try with 82 Ohms and check the result.

Hi Chris,

Yes. Seems like you have a valid point. I had tried with 33Ohms for damping, and it can be one of the reasons. Also I had tried to short the pins instead of 0E but the result was same. I will try to rig up properly and give a try again.

Thanks a lot.
Regards,
Girisha.

Girisha, I also noticed that resistors are in the wrong place, but as they are 0R on the circuit it did not matter. Now you say that your actually built circuit differs from the circuit diagram. Can you please make your circuit exactly as in reference schematic? Position of series resistor does not matter as long as they are 0R.

Hi Eugeny,

This is the reference circuit by Wiznet.

wizwiki.net/wiki/lib/exe/fetch.p … 150406.pdf
I am following the same schematics and part numbers.

Regards,
Girisha.

Bad link…

Please try this link
wizwiki.net/wiki/lib/exe/fetch.p … 150406.pdf

Sorry, you are right, I looked the the circuit diagram with external transformer!

As you say there’re several boards which behave this way, assuming that you do not have a batch of bad components, then something wrong is with circuit design or assembly. We have checked that your circuit, as it was drawn, seems to be ok. Can you please examine board assembly, or the best upload its hi-res images from both sides and share here so that we can have a look.

Hi All,

Thanks for the inputs. My board works fine now. It basically had 2 issues related to my board layout.

  1. Damping resistor and the 49R9 resistors were not placed properly (as you mentioned in previous post). Changing damping resistors from 33E to 0E helped. I will rectify the schematic and go with a new board.

  2. Layout also had issues with mapping pins with the LAN connector. Proper mapping was needed.

Solving 1 & 2 made things work for me.

Appreciate all your support. Thanks a lot.

Regards,
Girisha.

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.