Wiffi210 connection & disconnection (urgent)


#1

Hi,
What is the proper way of disconnecting from a Network??

I set up my WIFI-module as a server and connect to a PC in Adhoc-mode.

I use these commands:

Connect to WiFi-network:
AT+WWPA=password

Disable DHCP:
AT+NDHCP=0

set module Ip-Address and Gateway IP:
AT+NSET=192.168.1.1,255.255.255.0,192.168.1.2

set Wifi-parameters for auto-connect:
AT+WAUTO=2,MYadhocNetwork,0

Connect:
ATA

Connection is made…<

Now in data-mode, i cannot send any more commands to the module.

Now if want to disconnect again…
Question1: is the proper way of disconnecting, to send “+++” ?? do i have to issue a AT+XDUM=0 command first everytime?

Question2:
If i connect my computer to the adhoc-network first, it says “waiting for user”. As soon as i connect the WIFI-module (with ATA), the connection is made and the computer says “connected”. Everything is fine!
But if i connect the module first and then the computer, no connection is made. The computer says “waiting for user…” and nothing more happens. Can i force a connection to be made?

i could use the AT+PING command to see when the computer is connected and then issue a ATA command, but that won’t work since i’m not connected to the computer before ATA-command

Question3:
Can i send AT+Ping commands while in data-mode? The module is inresponsive in data-mode, so i’m not sure how to send additional commands without first exiting data-mode (with +++), which disconnects the server-client connection.

Note: i’m using a dfRobot Wifi-shield v2.2.Tried getting help from dFrobot, without success (yet)


#2

here is my settings (at&v)

at&v
ACTIVE PROFILE
C0 &Y0 E0 V1 B=115200,8,N,1 &K0 &R0
+NDHCP=0168.1.2
+DNS1=0.0.0.0, +DNS2=0.0.0.0
+WM=0 +WAUTO=2,"MYadhocNetwork",,
+WRE0.0.0.0,4000
+WAUTH=0 +WWPA="myPassword"+PSK-valid=0 +SSID=htech2
+WWEP1=000,26,,
S0=01000 S1=00500 S2=00500 S3=00003 S4=00010 S5=00150
+BDATA=0  +WSEC=XAIRCMDPORT=5001
+XDO=0,0,0 +XAR=0 +XUAP=0 +XPSO=0,0

#3

Hello hobbex

You can’t issue at-commands in data-mode.
If you want to disconnect it or issue additional command, WizFi210 should be transited into using “+++”.

Steve


#4

Thanks Steve,

So, what about my Question#2 regarding the adhoc-connection procedure?


#5

Here is my test scenario.

  1. configure WizFi210 as ad-hoc mode(ssid : dddddd)
    AT+NSET=192.168.12.254,255.255.255.0,192.168.12.1
    at+wd
    at+wa=dddddd (just test ssid)

  2. configure PC as ad-hoc mode(ssid : dddddd)
    In this step, I used with static ip.
    Then the ping-test worked well.
    How about test it again with another wireless utility(not zero configuration).
    I guess the problem is related with windows-wifi-configuration-program(zero configuration).

Steve