WIZnet Developer Forum

Wiz140sr buffer corruption

Using the latest f/w 1.6.5 we still see corrupted Tx data out serial ports.
The test case is simply sending approx. 1700 characters (32 lines of A-Z, a-z) to serial port 1 over LAN.
The 3th or 4th attempt shows corruption with previous message data.
The Tx data continues to be corrupted by old data if you send 100 or more space or CR .

Have to reset Wiz140 &/or drop connection (Putty) to clear the corrupted buffer.

Receiving from serial port seems to work okay.

We have worked around this issue with previous f/w by dropping connection (LAN) & restarting with every Tx message.
We don’t have this problem with any Moxa n-port servers.


Hi, Brett1.

Please check if there is a same problem in firmware version 1.6.4.

We will reply after checking the your problem.

Thank you.

We had the same/similar problem with this same module over 4 years ago.
We worked around the problem by dropping LAN connection with every message.

F/W 1.5.2 has similar corruption problem & the config tool baud rates are mixed up.

I politely request you perform my very basic simple test on your hardware on the different f/w versions.

Any tests that a customer uses that triggers a bug should be added to your test suite to prevent any f/w regressions. A similar problem (to this report) was reported some years ago.


Hello Brett1,

We’ve changed the buffer management scheme to fix the data corruption with Ver 1.5.x.
Recently we got another report of that FW 1.6.5 still have data corruption issue.
I checked buffer management logic carefully and found there is some possiblity of which data corruption happens.
We check the free buffer size of uart tx buffer and update it after transmitting data and storing data to tx buffer. This made buffer pointer variable mass up.
So we changed serial buffer management not to make data corruption.
We tested the new firmware v 1.6.6 for a long time internally and we saw that data corruption didn’t happen by now with v 1.6.6
So, I hope you test it on your side and report the test result first.

Please use the below link.
WIZ140SRv1_6_6_180709.bin (41.4 KB)

Thank you.

Hi James,
Very timely reply… Was just about to remove the module & bin it.

Using f/w 1.6.6 I have re-run simple test (exactly same as before) with 2k file with repeating character patterns.

Seems to work okay…
I tried repeatedly (& simultaneously) sending 2k blocks of text over the LAN to serial port & in reverse.
I don’t see any corruption so far…

Will now try testing the a very large block of data & then do comparison.

So looking good.
Thanks very much,

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.