Wiz107SR garbage data (RS232) {SOLVED}


#1

Hello Guys! On the picture bellow you can see the settings I have made on WIZ107SR in conf tool. The problem is that I am still getting Garbage data. I checked baud rates at least 5 times, but I didnt see anything wrong. Please help!

Product WIZ107SR
Configuration tool: 1.4.4.1
Firmware: 3_14.
PC interface: Device terminal 1.0

https://drive.google.com/file/d/0B_EYtdS7J5eKTk9SdW9uUGw1ajA/edit?usp=sharing

Thank you in advance!


#2

Hi,
Uncheck “enable debug message output”

If enabled, the debug message output to serial port number. It is useful for debugging WIZ107SR.

Thank you.


#3

Thank you for reply!
The purpose I use it is exactly to debug my serial connection, hence I was able to see it doesnt work. Nonetheless I unchecked the debug message, afterward I sent/received a single character data trough Device Terminal Program 1.0 and I still get corrupted data.


#4

Hi,
If the debug message display is no problem any more, the baud rate is likely to matter.

So, Please test as the below.

  1. Short TX/RX siganl with jumper or connect in WIZ107SR. (TX/RX loopback)
  2. Send data thru ethternet.
  3. Check the data to be received from ethernet.

Thanks.


#5

Thank you midnightcow!
I tried what you suggested. The result was [quote]LGSEG:CONNECTED[/quote]. Ok, so the device seems to work well in “stand alone mode”.
Then where am I wrong? I am pretty much sure it is on BAUD rate. Anyway, this is my test scheme:


WIZ107SR<--->max3232<--->RS232_USB_converter<--->PC

I am waiting for my oscilloscope to return from the service so I can determine tha actual BAUD rate.
A question is if the WIZ107SR serial port is TTL or RS232?
If the data being transmited is inverted or not?
Dont get me wrong, I have read the datasheet, but I have no idea what might be wrong in this case.


#6

WIZ107SR was released ‘TTL’ and ‘RS-232’ version both.
if you can find U2 ‘RS-232 transceiver’ (refer to WIZ107SR partlist) on your module, you have WIZ107SR RS-232 version and if not, it’s TTL version.
(Please check your board revision first. before revision 1.1 was released RS-232 version only.)

WIZ107SR RS-232 version is no need to use ‘TTL - RS-232 transceiver’ (like MAX3232).
if you want to use DB-9 port, please connect the port directly on the module.


#7

Thank you so much Guys!

Yes it has!
The problem was I put MAX3232 after the module which has already such.
Now everything work perfect.
Thank you again! :smiley: