How to set password on 107SR?

#1

Hello everyone. :slight_smile:

I have everything working fine on the 107SR module, including WAN access and everything - fantastic.

But no matter what I try, I can’t make the password feature work.

I am using the config tool 1.4.4.1
I can set all the paremetes etc fine, and I can set the password fine, but then the module flaty refuses any attempt to talk to it.

Example:

  1. From the config tool, click NETWORK tab, ensure radio dot is in ‘TCP Server’ option.
  2. Click SERIAL tab, un-tick ‘Enable debug message output’.
  3. Click OPTIONS tab, tick ‘Enable’ in ‘Connection password (TCP Server mode only)’
  4. Tick ‘Show Chars’ so I can see if I make a typo setting the password
  5. Enter a password in the ‘Password’ box - I just used PASS for the purposes of testing.
  6. Click SETTINGS to write the changes to the module.

All that completes fine, including writing the new settings.

Now:

  1. Open Tera Term
  2. Select IP address of module, and correct port number
  3. Tera Term establishes the connection, and you get the empty terminal window
  4. Try to enter the password

At this point, pressing ANY key, including capital P, and the 107 closes the connection.
I have not been able to find out how you get this to work, so would love anyone elese input here.

I have tried setting TT(Tera Term) to Line-At-A-Time mode=on and off - makes no difference other then the fact that with line-at-a-time off, any single keypress closes the connection, whereas with LAAT on, I can type all the characters of the password, but as soon as I press [ENTER], the connection is closed.

Does anyone have any bright ideas as to what I am doing wrong?

Module is 107SR ver 1.0, Firmware 1.0
I looked on WizNet site for updated software, but there does not seem to be any for the version 1.0 hardware.

I have a couple of new 1.3 modules coming to test, in case it is some kind of issue with the older 1.0 boards.

#2

Hi Grogster,
The WIZ107SR connection passwords must be entered separately without other characters like CR / LF (Carriage return, Line feed) in terminal.

I tested input the connection password using TeraTerm, I was found CR(0x0d) in the end of password string. (in wireshark packet captures) so, if you input the password to WIZ107SR TCP server using TeraTerm, the WIZ107SR recognized as invalid character. (e.g. ‘PASS’ => ‘PASS(CR)’)

if the WIZ107SR connection password option enabled and the input string is invalid password, the WIZ107SR terminates the connection. And the problem of the teraterm shutdown, please check(disable) the ‘Auto window close’ option in TeraTerm: TCP/IP setup.

I recommend that you use a another terminal program.

Regards,
Eric.

#3

Hello - thank you for your reply. I will investigate. Can you recommend a suitable terminal program?

#4

I recommend the ‘Hercules SETUP utility’ program.

Please refer to the next download link:
hw-group.com/products/hercules/index_en.html

Regards,
Eric.

1 Like