WIZnet Developer Forum

Wiz100sr connection problems

Hi,

I’m using WIZ100SR for the internet communication but I am a little bit disappointed. Old firmware returned wrong answer to via uart option so I tried upgrade to 5.11 firmware. This FW was wrong too, because I was unable to set UART code to enter uart configuration (with <+++> - FW before worked well). So I tried 5.10 and this FW worked good until I found a new bug:

When I switched WIZ100SR to DHCP I was unable to connect via uart configuration with my code (<+++>). When I switched back to STATIC uart mode worked well. Then I tried PPPoE and after that [size=150][color=#FF0040]I AM UNABLE to connect to WIZ100SR[/color][/size] (via UART or TCP config tool) :confused:

Is it some way to reset WIZ100SR to factory defaults?

Thanks,

Maros

Dear Maros

I need more info to reproduce your problem.
Please send screen images of CFG tool and test scenario in detail.
And if you can use Wireshark, please add Ethernet log of Wireshark.

Is it some way to reset WIZ100SR to factory defaults?
(WIZnet) Sorry. There is no factory reset in WIZ100SR because there is no HW pin for factory reset.

You can get the latest firmware from the following site.
old.wiznet.co.kr/sub_modules/en/ … F_KeyWord=

Thanks.

Hi,

I could not give you screenshot because there is nothing to show. After entering PPPoE I am unable to SEARCH device via CFG tool ( WIZ connected directly to PC) so I cant see my device. And what is worse - I cant connect to wiznet via uart with <+++> command - there is no response from uart. I tried almost every uart settings and baudrates…

So again:
When it was in static mode, everything worked! When I entered DHCP I couldnt connect to wiznet via UART but with CFG tool it was possible. When I switched (just for test) into PPPoE mode I was unable to connect via uart and CFG tool.

And it is really bad that wiznet doesnt have any factory reset. You dont need to have any special pin for this. Some modules uses grounding of some pin after startup. It is really bad because when communication goes down I can throw this module out the window… :confused:

I solved part of the problem. I connected wiznet directly to PC and I overloaded UART with <+++> commands and voila:
wiz100sr was discovered by CFG tool. So I switched back to static and now I am able to connect with wiz100sr.

BUT

[size=150]There is still problem[/size] with DHCP configuration. I attached some file.

  1. At first, look at static.jpg. As you can see - I sent <+++> command and wiz100sr replied. Dont be confused that I am sending <<++> - it is how the hercules translate special ascii names. In window (pink color) you can see that message is <+++>. So it is correct. Black color is answer from wiz100sr.

  2. Via CFG tool I switch to DHCP and you can see that wiz100sr DOESNT reply!!! (dhcp.jpg)

  3. After that I switch back to STATIC (I didnt clear terminal window for better understanding) and as you can see - wiz100sr replies AGAIN! (back from dhcp to static.jpg)

So there is problem with DHCP mode. My question is WHY and how to solve it :slight_smile:



Thank you for your info.
I will post the result after checking.

Thanks. I tried the newest FW 5.13 and the problem still remains…

Now I discovered another problems after upgrade to 5.13.

UART communication works well, but TCP/IP protocol not. I attached another pictures. On picture you can see some wrong data in the textboxes.

On 3rd picture I want to downgrade to 5.10 but as you can see, it doesnt work and it generates another wrong data in the textboxes…

[size=150]As you can see part of DNS nameserver appears in TCP/IP password texbox!!! So there is a problem with overflow of memory…[/size]



pictures 4 and 5… thank you. I am not new in software and electronic engineering - so I think that this is not my mistake but something is wrong with WIZ firmware…



Dear Macro

First of all, you must use correct commands.
Please refer to attached image.
And read User Manual fully.
old.wiznet.co.kr/sub_modules/en/ … F_KeyWord=

Second, "Version 82.0 " means that FW Upload is not completed.
You must carry out FW Upload again.

Thanks.


I am reading user manual 2.1.0 and there is NO information about what is 82 version of firmware. But thanks for information!

AND sorry - I was sending <+++> command from terminal, but in my code is only +++.

I tried only +++ in DHCP mode via terminal and still without success, I dont understand :cry:

I recorded video how I am testing it:

youtube.com/watch?v=IWYa-4lxaeo

Is there something wrong? I tried also HW reboot after entering DHCP mode… THANK YOU

Could you post your source code partially?
I will inspect UART code. I guess that there is unnecessary code.
And please try to test by other serial tool.
sites.google.com/site/terminalbpp/

Thanks.




Hi Jim,

thank you for your patience. But did you watch my video on youtube? There is only WIZNET and terminal with +++ command and command. As you can see when I have STATIC mode everything works, but with DHCP not. WIZNET is directly connected with USB/TTL UART 3.3V.

In WIZNET I do not have the ethernet cable but this can not be a problem… because I have to communicate with WIZNET before ethernet connection. Because:
My user for example accidentally switch from STATIC to DHCP on his device where wiznet is. His router do not have DHCP mode enabled - so WIZNET do not have assigned an IP - and when UART mode does not work - he has a problem :slight_smile:

I will try another terminal consoles but I do not have any problem with Hercules…

I saw your movie of test.
I think DHCP operation is failed because there is no change of local IP after DHCP setting.
Please activate “Enable Serial Debug Mode”.
test again and add logs of serial port.

And could you show me your AP network setting?

Thanks.


Yes, When I switch to DHCP after a few seconds I have this message from Serial Debug Mode:

DHCP failed

But this is of course right, because I do NOT have ethernet cable plugged in so DHCP server cannot assigned IP settings. Again I have to configure my device with or without network.

Imagine, that you are common user and you want to configure the device. You have Static IP mode on your router and you do not have access to this router - because you are common user. And now you made a mistake - accidentally enable DHCP mode! So your router doesnt assigned you IP because it is in STATIC mode. Now you realize a mistake but it cannot be undone - because you cannot access to wiznet via my UART application anymore… the only way how you could repair it is use your wiznet CFG tool. But this is totally bad for common user - some users do not have access to install SW…

:question:

AT commands will be normal after getting DHCP IP.
Other operation is blocked except DHCP operation until DHCP IP is received from AP.

When you want to change options, please use static IP in CFG tool.

Thanks.

:frowning: But I dont understand why it is not possible. UART console on every network device is for configuration when something is wrong with the network - Here somebody just cut cable from wiznet and after that all my uart communication is not possible… this is a BIG BIG disadvantage :frowning:

Is possible to correct it in a new firmware release?

Sorry. WIZ100SR is old model. The history of WIZ100SR is very complicated.
I can’t guarantee FW from side effect.

Thanks.

<P.S.>
I recommend WIZ550S2E solution.
WIZ550S2E FW is flexable and open platform.
old.wiznet.co.kr/sub_modules/en/ … 0&pid=1234

OK, thank you for your patience! I dont like your last answer because I have to make changes in our design :smiley: I will add reset button to STATIC mode via Ethernet connection if something goes wrong…

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.