WIZnet Developer Forum

Wizfi360io-h for 'transparent mode'

Just saw your product on the digikey site. I would like to confirm if it will meet our needs.

Currently we use a PC/linux base TCP client program to communicate (send/receive data) with a wifi module. The module is connected to one of the processor UART ports.
I have used the Digi xbee wifi SB6 module (in transparent mode) as well as the Silicon Labs AMW006-a1u and AMW006-a1w in TCP server mode and both work. I have used both because of their through-hole footprint.
The communication does not use any ‘AT’ commands, just sending/receiving hex bytes.
Can i use the wizfi360io-h similarly, and do you have examples of how to set up the module.

Hi
WizFi360io-h also provide transparent mode. so you can send/receive the messages without the AT commands .
but you should use the AT commands to make a TCP Server mode.
the module supports auto-connection mode, but it only works on the TCP Client mode.

You can refer to the following link to set up the module.
I recommend you a " AT Command Examples V1.0.3 - English to set up the module.

There are the all of documents about the WizFi360 module.
https://wizwiki.net/wiki/doku.php/products:wizfi360:wizfi360ds:start

Thanks, i will go ahead and place an order to evaluate.
Does this module have a u.fl connector option for an external antenna (or you have another module with this option).

Hello. I am testing Wizfi360io-h transparent mode without success
Here is the LOG:
AT+RESTORE=1

OK

ready
AT+GMR
AT version:1.1.0.5(Feb 6 2020 09:52:17)
SDK version:3.2.0(a0ffff9f)
compile time:Feb 6 2020 09:52:17

OK
AT+CWMODE_DEF=1

OK
AT+CIPSTA_DEF=“192.168.0.81”,“192.168.0.1”,“255.255.255.0”

OK
AT+CWJAP_DEF=“linksys”,“xxx1xxx”
WIFI CONNECTED
WIFI GOT IP

OK
AT+CWAUTOCONN=1

OK
AT+CIPSTART=“UDP”,“192.168.0.8”,5000
CONNECT

OK
AT+CIPSEND=10

OK

busy s…

Recv 10 bytes

SEND OK

+IPD,35:Replied from Kurtev to “1234567892”
AT+CIPMODE?
+CIPMODE:0

OK
AT+CIPMODE=1

OK
1234567892

ERROR
1234567892

ERROR
1234567892123456789212345678921234567892

ERROR
AT+CIPSEND=10
IPMODE=1

ERROR
AT+CIPMODE?
+CIPMODE:1

OK

When +CIPMODE=0 successfull sending and receiving, when +CIPMODE=1 - module still executes AT commands and gives an error on "1234567892"message.

WizFi360io-h series does’t have u.fl option.

I tested UDP transparent mode like you did and I saw same problem.
I will inform this issue to dev team.
Thanks for your information.

Hi. Same is the situation and in TCP client mode. Currently I am using WIZ750sr-100 and it is working in transparent mode in both TCP client/server . Are you going to support TCP server transparent mode?

Hi.
We support transparent mode on TCP client mode instead of TCP Server mode.
Because TCP server mode have to manage multiple connection in our structure of the module.(mandantory AT+CIPMUX=1)
as you know, transparent mode is not available in the multi connection state.

I guess AT+CIPMODE command has a bug.
It will be fix. before that you can use transparent mode in TCP client mode with AT+SAVETRANSLINK command.
for example.

AT+CWMODE_DEF=1
AT+CWDHCP_DEF=1,1
AT+CWJAP_DEF="AP_SSID","AP_PASSWORD"
AT+CWAUTOCONN=1
AT+SAVETRANSLINK=1,"192.168.0.194",5000,"TCP"
AT+RST

Hello. Yes , tested this also and again no transperancy. So I will wait for updated firmware with fixed bug

Hello, It is not a Bug.

After set “AT+CIPMODE=1\r\n”, We must send message “AT+CIPSEND\r\n” so WizFi360 is Transmode.
Please see my log.

{

(19:40:17.256) ready
(19:40:40.673) AT+CWMODE_DEF=1
(19:40:40.752) AT+CWMODE_DEF=1
(19:40:40.752)
(19:40:40.752) OK
(19:40:48.369) AT+CIPSTA_DEF=“192.168.0.81”,“192.168.0.1”,“255.
(19:40:48.463) AT+CIPSTA_DEF=“192.168.0.81”,“192.168.0.1”,“255.
(19:40:48.519) 255.255.0”
(19:40:48.576) 255.255.0”
(19:40:48.611)
(19:40:48.611) OK
(19:40:59.308) AT+CWJAP_CUR=“Teddy_AP”,“12345678”
(19:40:59.401) AT+CWJAP_CUR=“Teddy_AP”,“12345678”
(19:41:02.747) WIFI CONNECTED
(19:41:03.363) WIFI GOT IP
(19:41:03.363)
(19:41:03.363) OK
(19:41:24.449) AT+CIPSTART=“UDP”,“192.168.0.2”,5000,6000
(19:41:24.516) AT+CIPSTART=“UDP”,“192.168.0.2”,5000,6000
(19:41:24.516) CONNECT
(19:41:24.516)
(19:41:24.516) OK
(19:41:44.603) AT+CIFSR
(19:41:44.675) AT+CIFSR
(19:41:44.675) +CIFSR:STAIP,“192.168.0.81”
(19:41:44.675) +CIFSR:STAMAC,“00:08:dc:36:04:d0”
(19:41:44.675)
(19:41:44.675) OK
(19:42:00.201) AT+CIPSTATUS
(19:42:00.297) AT+CIPSTATUS
(19:42:00.297) STATUS:3
(19:42:00.297) +CIPSTATUS:0,“UDP”,“192.168.0.2”,5000,6000,0
(19:42:00.297)
(19:42:00.297) OK
(19:42:19.650) AT+CIPSEND=10
(19:42:19.743) AT+CIPSEND=10
(19:42:19.743)
(19:42:19.743) OK
(19:42:19.743) >
(19:42:24.458) 0123456789
(19:42:24.560)
(19:42:24.560) Recv 10 bytes
(19:42:24.560)
(19:42:24.560) SEND OK
(19:43:03.153) AT+CIPMODE=1
(19:43:03.232) AT+CIPMODE=1
(19:43:03.232)
(19:43:03.232) OK
(19:43:09.199) AT+CIPMODE?
(19:43:09.293) AT+CIPMODE?
(19:43:09.293) +CIPMODE:1
(19:43:09.293)
(19:43:09.293) OK
(19:43:16.089) AT+CIPSEND
(19:43:16.190) AT+CIPSEND
(19:43:16.190)
(19:43:16.190) >
(19:43:25.712) 0123456789
(19:43:28.281) 0123456789
(19:43:46.732) Test Loop Back

}
and result

OK. I understsand. Now have success. After AT+SAVETRANSLINK , RESTART and switching ON is very unconfortable to send AT command in order to start working in transparent mode. I would like to suggest you to skip this step in future firmwares. Thanks for the support.

Ok, I will consider function of that after.

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.