Error Message on System Status Request


#1

Hi,

I try to poll the module with the serial command in order to get information about the connection status.
My module is not connected to any wireless network and responses with error number 4.

Is the command not suitable for this condition(altough it should be because it has a detail about connected or not) or do you have an alternative ?


#2

Hello Nils333

Return Code 4 : Not supported command in current running

Please be sure that the operation mode is .
In another mode, it will return 4.

Steve


#3

Hi,

our currently prefered mode is AP client with setting of Multi Bridge Mode.

Where do I have to keep the setting to Client Mode else ?


#4

Hi

you can use command in AP-Client mode. Please refer this command list.
It is serial command list for using AP-Client mode. Red color is command and black color is response message.

[color=#FF0000][/color]

[color=#FF0000][/color]
<S_xxxx>
[color=#FF0000]<PU5_2_6_1_123456789>[/color]

[color=#FF0000]<PIWiznetKaizen_123456789>[/color]
<4> <-- If you show this response, Don’t care.
[color=#FF0000][/color]

[color=#FF0000][/color]
[color=#FF0000][/color]
<S1_WiznetKaizen_0026667B9DB0_1_150_44>


#5

Hi,

sorry I tried your settings, but it doesn’t work, the result is still <4>.

By the way, what is the difference in function of the command pairs AU/PU and DU/GU ?
In my understanding the AU/PU is used in order to set the security of the modules client function relative to the AP ?

How is the modules AP function used ?
Does the module share the SSID of the upper AP for its own AP function ?

Is the DU/GU used for operation modes other than AP Client Multibridge Mode ?


#6

Hi

sorry I tried your settings, but it doesn’t work, the result is still <4>.
[color=#FF0000]I want to check your WizFi630’s Operation Mode using command. is it changed to ? Please check this point.
And I want to know your WizFi630’s S/W version as 1.1.25(20120726).[/color]

By the way, what is the difference in function of the command pairs AU/PU and DU/GU ?
In my understanding the AU/PU is used in order to set the security of the modules client function relative to the AP ?
How is the modules AP function used ?
Does the module share the SSID of the upper AP for its own AP function ?
Is the DU/GU used for operation modes other than AP Client Multibridge Mode ?

[color=#FF0000]In AP-Client Mode, command will change client side’s security value of WizFi630. But command will change ap side’s security value of WizFi630.
[/color]

[color=#FF0000]Using / and , It will change value in order to connect to upper AP as below.[/color]


[color=#FF0000]Using / and /, It will change value in order to WizFi630’s SSID and Security type as below.[/color]


Thank you.


#7

Hi,

the after command is confirmed.
My module has got the serial number <Sv1.1.24>

I also tried with a module, having the <Sv1.1.25> with the same result.

What is the general reaction of the command ? Does it work in correct manner, if the module has got an establshed connection or what can affect the commands always response with message <4> ?


#8

Hi nils

I did identify the problem about this issue.
In 1.1.24 and 1.1.25, WizFi630 always output message <4> after enter command.
But in 1.1.29, We fixed this problem. So I will send this firmware to you via your mail.

I hope this solution is of help.

Thank you.


#9

Hello,

yes thank you very much, the new firmware works fine.


#10

Hi again,

this morning I tested the firmware and first I got a for no connection and after that, connection and the correct response.

This afternoon I performed some more tests and the connection is good and stable, web server tells me connection, but status telegram always tells me .

What may have happen ?


#11

Hi

Yesterday, I did test about this issue until 12 hours. But it didn’t occur to me.
What is difference between my test environment and your environment?
So I will explain my environment then please check difference.

My Environment

WizFi630 set AP-Client Mode and connect to AP. Wizfi630 received IP address from AP and I can receive serial response of command via PC. After 12 hours, I can receive response message of command like [color=#FF0000]<S1_WiznetKaizen_0026667B9DB0_7_150_88>[/color].


Please check difference between you and I.